Back to overview
Degraded
Brief API latency spike
Jun 1, 2026 at 8:14am UTC
Affected services
API Health
Email API
Resolved
Jun 1, 2026 at 8:24am UTC
Resolved — API response times have returned to normal after recycling the database connection pool. We are monitoring closely.
Affected services
Created
Jun 1, 2026 at 8:14am UTC
We are investigating elevated response times on the API. Some requests may be slower than usual.
Affected services