Back to overview
Degraded
Degraded SMTP relay performance
May 16, 2026 at 11:40am UTC
Affected services
SMTP Server
Resolved
May 16, 2026 at 11:55am UTC
Resolved — maintenance completed and SMTP relay performance is back to normal. All queued messages have been delivered.
Affected services
Created
May 16, 2026 at 11:40am UTC
We are investigating slow connection handshakes on the SMTP relay.
Affected services